Apache Tomcatに脆弱性(CVE-2026-87022)
概要
Apache Tomcatに脆弱性が確認されました。
バージョン 11.0.0-M1 以上 11.0.25 以下、10.1.0-M1 以上 10.1.59 以下、8.5.0 以上 8.5.100 以下、7.0.56 以上 7.0.109 以下に影響があります。
脆弱性の基本情報
| 脆弱性ID | CVE-2026-87022 |
|---|---|
| 脆弱性の種類 | CWE-130 |
| 危険度 | 高 |
| CVSSスコア |
7.5(CVSS v3.1) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N |
| 公開日 | 2026年9月23日 |
影響を受ける製品
| 製品 | 影響を受けるバージョン | 修正版 | 出典 |
|---|---|---|---|
| Apache Tomcat |
11.0.0-M1 以上 11.0.25 以下、10.1.0-M1 以上 10.1.59 以下、8.5.0 以上 8.5.100 以下、7.0.56 以上 7.0.109 以下 | — | CVE List(CVE Program) |
推奨対応
- Apache Tomcatの提供元が公開している最新情報を確認し、公式の最新版へ更新してください。
情報元の原文
CVE List(CVE Program)
Apache Tomcat: WebSocket message smuggling with per-message-deflate
Improper handling of length parameter inconsistency vulnerability in Apache Tomcat allows WebSocket message smuggling when per-message-deflate is used.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121.
The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.56 through 7.0.109. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.1.22, which fix the issue.
利用条件:CVE の利用条件(CVE Terms of Use)・原文のまま掲載
Copyright 1999-2026 The MITRE Corporation
CVE Usage: MITRE hereby grants you a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, sublicense, and distribute Common Vulnerabilities and Exposures (CVE®). Any copy you make for such purposes is authorized provided that you reproduce MITRE's copyright designation and this license in any such copy.
情報元
- CVE List(CVE Program)
https://www.cve.org/CVERecord?id=CVE-2026-87022